Banner Issues
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Jan 06, 2020 - 20:05 EST
Update
We are continuing to investigate this issue.
Posted Jan 06, 2020 - 16:05 EST
Investigating
We are currently investigating this issue.
Posted Jan 06, 2020 - 15:36 EST
This incident affected: Academic Services (Banner and Genisys).