Avaya phone system lost connection
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Jul 20, 2022 - 13:52 EDT
Update
We are continuing to investigate this issue.
Posted Jul 20, 2022 - 10:44 EDT
Investigating
We are currently working on getting the system back online.
Posted Jul 20, 2022 - 10:41 EDT
This incident affected: Telephones (Phones).