Password reset page not displaying anything
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Mar 26, 2021 - 13:41 EDT
Investigating
We are currently investigating this issue.
Posted Mar 26, 2021 - 08:18 EDT
This incident affected: Identity Management and Logon Services (Self Service Password Change).