Student Center Network Issues
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Jan 17, 2023 - 19:05 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 17, 2023 - 18:27 EST
Investigating
We are currently investigating this issue.
Posted Jan 17, 2023 - 15:21 EST
This incident affected: Network (Campus Network).