Email bounce back issues when sending from @regent.edu email account
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Oct 18, 2021 - 19:43 EDT
Investigating
We are currently investigating this issue.
Posted Oct 18, 2021 - 16:06 EDT
This incident affected: Email (Faculty and Staff Microsoft Office 365 Outlook Mail).