Banner and Genisys issues
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Jan 11, 2020 - 17:58 EST
Investigating
We are currently investigating this issue.
Posted Jan 11, 2020 - 16:27 EST
This incident affected: Academic Services (Banner and Genisys).