Issues logging into MyRegent
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Aug 04, 2022 - 22:43 EDT
Investigating
We are currently investigating this issue. Students are able to log into Blackboard directly at the website
https://regent.blackboard.com/webapps/login/?action=relogin
Posted Aug 04, 2022 - 22:01 EDT
This incident affected: Regent Websites (my.regent.edu).