Citrix Discoverer issues
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Nov 25, 2019 - 09:33 EST
Investigating
We are currently investigating this issue.
Posted Nov 25, 2019 - 08:34 EST
This incident affected: Networking Systems (Citrix).