Library Portal Currently Down For Maintenance
Incident Report for Regent University
Resolved
Maintenance complete, Library Portal and Library Link are operational.
Posted Oct 02, 2019 - 12:52 EDT
Identified
Library Portal is currently undergoing maintenance.
Posted Sep 25, 2019 - 08:42 EDT
This incident affected: Academic Services (Library Portal).