DegreeWorks access issues
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Jan 15, 2020 - 22:24 EST
Update
We are continuing to investigate this issue. We are currently investigating the issue. Able to duplicate the issue with computers on the student network on campus. Computers off of the student network do not have the same issue.
Posted Jan 15, 2020 - 22:10 EST
Investigating
We are currently investigating the issue. Able to duplicate the issue with computers on the student network on campus. Computers off of the student network do not have the same issue.
Posted Jan 15, 2020 - 15:06 EST
This incident affected: Academic Services (Degree Works).