My.Regent.edu Outage
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Sep 24, 2021 - 07:14 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 23, 2021 - 20:15 EDT
Investigating
We are currently experiencing an outage with the My Regent Portal system. Our engineers are aware of the situation and are working to resolve the issue as soon as possible. Please use the following URL addresses for direct system access.

Blackboard | regent.blackboard.com
Outlook for Faculty and Staff | regent.edu/outlook
Posted Sep 23, 2021 - 16:55 EDT
This incident affected: Regent Websites (my.regent.edu).