Issues accessing TouchNet
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Aug 12, 2022 - 11:21 EDT
Investigating
We are currently investigating this issue.
Posted Aug 12, 2022 - 10:36 EDT
This incident affected: Academic Services (Banner and Genisys).