Student Center Network Connectivity Issues
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Jan 18, 2023 - 13:11 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 18, 2023 - 11:02 EST
Investigating
We are currently investigating this issue.
Posted Jan 18, 2023 - 09:21 EST
This incident affected: Campus Services (Campus Computing).