Blackboard Grade Center intermittently functioning
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Jan 15, 2021 - 14:57 EST
Investigating
We are currently investigating this issue.
Posted Jan 13, 2021 - 14:04 EST
This incident affected: Blackboard and Learning Technology (Blackboard Learn).