Five9 Call center issues
Incident Report for Regent University
Resolved
This incident is resolved.
Posted Sep 29, 2021 - 08:03 EDT
Investigating
We are currently investigating the issue. The call center is experiencing residual issues from yesterday's outage.
Posted Sep 28, 2021 - 10:56 EDT
This incident affected: Telephones (Call Center).