Web Outlook and Skype login issues
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted May 14, 2020 - 14:28 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 14, 2020 - 06:53 EDT
Update
Microsoft is aware of the issue with the web version of Outlook. As a temporary solution, please use Google Chrome to prevent the page from redirecting.
Posted May 13, 2020 - 14:01 EDT
Investigating
We are currently investigating this issue.
Posted May 13, 2020 - 13:44 EDT
This incident affected: Email (Faculty and Staff Microsoft Office 365 Outlook Mail).