Pearson MyLab Error
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Feb 06, 2020 - 16:10 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 06, 2020 - 10:20 EST
Investigating
We are currently experiencing an error with Pearson MyLab. When users click on the tool, it will take them back to their Blackboard Home Page. We are working with Blackboard to resolve this issue and apologize for inconvenience.

- TLTS
Posted Feb 06, 2020 - 10:13 EST
This incident affected: Blackboard and Learning Technology (Blackboard Learn).