Citrix Issues
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Apr 07, 2020 - 16:32 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 07, 2020 - 13:32 EDT
Investigating
We are currently investigating the issue.
Posted Apr 07, 2020 - 13:07 EDT
This incident affected: Networking Systems (Citrix).