Citrix outage
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Oct 21, 2019 - 09:05 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 21, 2019 - 08:49 EDT
This incident affected: Networking Systems (Citrix).