On campus student printing
Incident Report for Regent University
Resolved
The issue will be resolved after the holiday break.
Posted Dec 17, 2021 - 10:52 EST
Identified
Intermittent issue with on-campus printing from lab computers. Mobile printing not functioning.
Posted Dec 16, 2021 - 10:43 EST
This incident affected: Campus Services (Campus Computing).