Blackboard website issues
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Oct 07, 2019 - 19:48 EDT
Investigating
We are currently investigating this issue.
Posted Oct 07, 2019 - 17:48 EDT
This incident affected: Blackboard and Learning Technology (Blackboard Learn).