Issues logging into computers on campus
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Jul 13, 2020 - 13:01 EDT
Investigating
We are currently investigating the issue with logging into Citrix.
Posted Jul 13, 2020 - 09:09 EDT
This incident affected: Network (Campus Network).