Campus Power Outages
Incident Report for Regent University
Resolved
Power has been restored
Posted Aug 05, 2020 - 06:27 EDT
Update
Metroplex is also without power.
Generator power in LIB, RH, and COM.
No estimated time to restore at this time.
Posted Aug 04, 2020 - 16:17 EDT
Investigating
Regent University is experiencing power outages in the following buildings:

Library
Admin
CRB
Roberston Hall
Founders Inn
Posted Aug 04, 2020 - 15:49 EDT
This incident affected: Network (Campus Network) and Campus Services (Campus Computing).