MyRegent login or cas.regent.edu not responding.
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Jan 09, 2020 - 19:37 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 09, 2020 - 19:31 EST
Investigating
We are currently investigating this issue.
Posted Jan 09, 2020 - 18:58 EST
This incident affected: Regent Websites (my.regent.edu).