Issues connecting to Citrix
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Nov 11, 2020 - 16:28 EST
Investigating
We are currently investigating this issue.
Posted Nov 11, 2020 - 14:00 EST
This incident affected: Networking Systems (Citrix).