MyRegent portal down
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Jan 10, 2022 - 14:08 EST
Investigating
We are currently investigating this issue.
Posted Jan 10, 2022 - 13:42 EST
This incident affected: Regent Websites (my.regent.edu).