Cognos issues
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Sep 12, 2022 - 09:51 EDT
Investigating
We are currently investigating this issue.
Posted Sep 12, 2022 - 09:22 EDT
This incident affected: Academic Services (Cognos).