MyRegent Portal is currently experiencing issues
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Aug 12, 2021 - 15:49 EDT
Investigating
Semester check-in issues. We are currently investigating this issue.
Posted Aug 12, 2021 - 12:40 EDT
This incident affected: Regent Websites (my.regent.edu).