MyRegent portal issues
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Nov 04, 2020 - 10:34 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 04, 2020 - 10:23 EST
This incident affected: Regent Websites (my.regent.edu).