Citrix Logon issue
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Sep 30, 2020 - 12:14 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 30, 2020 - 09:33 EDT
Investigating
Users connecting with a Regent provided thin client are receiving an error message "SSL Error 4: Mocana SSL error 24"
Posted Sep 30, 2020 - 08:58 EDT
This incident affected: Networking Systems (Citrix).