Regent Security Awareness Training Portal Exepriencing Authentication Issues
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted May 01, 2020 - 12:26 EDT
Investigating
We are currently investigating this issue.
Posted Apr 30, 2020 - 16:30 EDT
This incident affected: IT Security (Cloud App Security).