MyRegent login issues
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Jan 22, 2021 - 16:54 EST
Update
We are continuing to investigate this issue.
Posted Jan 22, 2021 - 14:13 EST
Investigating
We are currently investigating this issue.
Posted Jan 22, 2021 - 13:46 EST
This incident affected: Regent Websites (my.regent.edu).