Admin Building UPS Failing
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Aug 03, 2020 - 12:24 EDT
Identified
We are currently experiencing intermittent UPS failures impacting the network in the Admin building.

We are replacing the failing unit as soon as possible.
Posted Aug 03, 2020 - 10:29 EDT
This incident affected: Network (Campus Network).