Internet issues at Foundation Hall
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Nov 24, 2019 - 21:10 EST
Investigating
We are currently investigating this issue.
Posted Nov 24, 2019 - 20:36 EST
This incident affected: Network (Campus Network).