MyRegent Portal Temporary Outage
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Jan 12, 2023 - 11:55 EST
Investigating
We are currently investigating this issue.
Posted Jan 12, 2023 - 11:46 EST
This incident affected: Regent Websites (my.regent.edu).