Blackboard not loading
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Sep 07, 2022 - 14:11 EDT
Investigating
We are currently investigating this issue.
Posted Sep 07, 2022 - 13:38 EDT
This incident affected: Blackboard and Learning Technology (Blackboard Learn).