Microsoft Teams
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Feb 04, 2020 - 11:19 EST
Monitoring
A fix has been implemented on Microsoft's side, we are monitoring for further issues.
Posted Feb 04, 2020 - 08:31 EST
Investigating
There is a nation wide Microsoft Teams issue. Microsoft is currently looking into it.
Posted Feb 03, 2020 - 10:36 EST
This incident affected: Campus Services (Azure Dev Tools for Teaching).