Regent Portal
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Jan 16, 2020 - 09:30 EST
Investigating
We are currently investigating the issue.
Posted Jan 16, 2020 - 08:14 EST
This incident affected: Regent Websites (my.regent.edu).