Citrix Outtages
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Nov 30, 2023 - 18:40 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 30, 2023 - 12:50 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 30, 2023 - 12:49 EST
Investigating
Citrix is currently experiencing outages. Additional updates can be viewed at https://status.cloud.com
Posted Nov 30, 2023 - 11:56 EST
This incident affected: Networking Systems (Citrix).