File Storage Access Issues
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Oct 27, 2021 - 16:11 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 27, 2021 - 15:17 EDT
This incident affected: Campus Services (Campus Computing).