MBS Bookstore website outage
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Oct 20, 2019 - 19:13 EDT
Investigating
We are currently investigating this issue.
Posted Oct 19, 2019 - 16:29 EDT