Panopto links in Blackboard getting an error message
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Aug 13, 2021 - 11:07 EDT
Investigating
We are currently investigating this issue.
Posted Aug 12, 2021 - 13:05 EDT
This incident affected: Blackboard and Learning Technology (Panopto).