Banner slow to respond
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Jul 28, 2020 - 08:10 EDT
Investigating
We are currently investigating this issue.
Posted Jul 27, 2020 - 17:40 EDT
This incident affected: Academic Services (Banner and Genisys).