Issue with Microsoft Teams
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Feb 18, 2021 - 10:18 EST
Investigating
We are currently investigating this issue.
Posted Feb 17, 2021 - 10:10 EST
This incident affected: Email (Faculty and Staff Microsoft Office 365 Outlook Mail).