Citrix Unavailable
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Nov 13, 2018 - 12:29 EST
Update
We have opened a ticket with Citrix and we are still investigation
Posted Nov 13, 2018 - 11:15 EST
Investigating
Citrix Services are currently unavailable.
Posted Nov 13, 2018 - 09:47 EST
This incident affected: Networking Systems (Citrix).