my.regent.edu is not reachable by Faculty and Staff
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Aug 30, 2020 - 11:07 EDT
Identified
All Deployments - internet backbone provider outage resulting in failed authentication attempts to integrations and login issues to the Duo Admin PanelSubscribe
Identified - We have confirmed that an outage at a major Internet backbone provider is causing connectivity issues to the Duo service for some customers.
We are engaged with relevant partners and are closely monitoring the situation.
Impacted customers may be able to work around the issue by using an alternate Internet connection or ISP to access the Duo service.
Aug 30, 10:22 EDT
Investigating - We are currently investigating customer connectivity issues to the Duo service, impacting the ability to access the Duo Admin Panel or authenticate against Duo protected applications. This appears to be caused by a major Internet backbone provider outage which has disrupted access to multiple Internet destinations.

Impacted customers may be able to work around the issue by using an alternate Internet connection or ISP to access the Duo service.
Aug 30, 09:22 EDT
Posted Aug 30, 2020 - 11:00 EDT
This incident affected: Regent Websites (my.regent.edu).