my.regent.edu Outage
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Aug 16, 2022 - 14:06 EDT
Investigating
We are currently investigating this issue.
Posted Aug 16, 2022 - 13:42 EDT
This incident affected: Regent Websites (my.regent.edu).