External Mail Flow Severely Degraded
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Apr 14, 2020 - 16:57 EDT
Monitoring
External Mail is flowing again. Please be aware that there may be delivery delays.
Posted Apr 14, 2020 - 14:32 EDT
Update
A fix is underway for this issue. Mail flow appears to be returning to normal, expect some delays as the queue backlog is processed.
Posted Apr 14, 2020 - 14:04 EDT
Identified
Issue identified with our Proofpoint Mail Security provider. Emergency maintenance on the vendor side is underway. Currently no ETTR is available.
Posted Apr 14, 2020 - 13:47 EDT
This incident affected: Email (Faculty and Staff Microsoft Office 365 Outlook Mail).