Listserv services are currently unavailable
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Oct 01, 2020 - 13:27 EDT
Investigating
We are investigating the issue and will update you once it is resolved.
Posted Oct 01, 2020 - 08:33 EDT
This incident affected: Email (Faculty and Staff Microsoft Office 365 Outlook Mail, Student Gmail by Google).