Phone Maintenance On Campus PBX
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Jan 17, 2023 - 21:46 EST
Update
We are continuing to investigate this issue.
Posted Jan 17, 2023 - 21:46 EST
Update
Phone maintenance is over. Phones are now back up and operational. Thank you!
Posted Jan 17, 2023 - 21:45 EST
Investigating
Phones will be offline starting at 9 pm lasting about 1 to 2 hours to do maintenance.
Posted Jan 17, 2023 - 20:08 EST
This incident affected: Telephones (Phones).